Trucchi assortiti

Da UZ wiki.

Gmail, Firefox e font proporzionali

Leggendo la posta con Gmail, può capitare di avere la necessità di visualizzare il testo con un font proporzionale (ovvero con caratteri di larghezza fissa).

Invece di impostare un tale font come carattere di default globale di Firefox, si può localizzare la configurazione del carattere da utilizzare al riquadro usato da Gmail per visualizzare il testo delle email.

Per farlo, dovete aggiungere le seguenti righe al file userContent.css, che si trova nella directory chrome all'interno del vostro profilo di Firefox (se non c'è, createlo).

 div.msg div.mb {
   font-family: monospace !important;
   font-size: 12px !important;
 }

Il profilo di Firefox si trova in una directory della forma

 .mozilla/firefox/m15k39br.default/

nella vostra home.

carattere È sulla tastiera italiana

In Linux, che è un sistema operativo serio, potete inserire i caratteri maiuscoli È, É, Ò, À, Ù premendo il tasto di blocco maiuscole (caps lock) e poi la lettera accentata corrispondente. Se vi interessa poi ci sono anche Ç, Ñ, Æ, Ð, Ħ, Ł, Ŧ, Ø, Þ (altgr+qualche lettera). Un modo analogo per inserire il carattere À è premere Alt+ù (accento acuto), e in seguito A. Combinazioni interessanti sono

 Alt+ù applicato ad Alt+ù aA  eE  iI      oO    uU    : ` àÀ  èÈ  ìÌ      òÒ    ùÙ     (grave accent)
 Alt+, applicato ad Alt+, aAcCeE  iI  lLnNoOrRsSuUyYzZ: ´ áÁćĆéÉ  íÍ  ĺĹńŃóÓŕŔśŚúÚýÝźŹ (acute accent)
 Alt+" applicato ad Alt+"                 oO    uU    : ˝                 őŐ    űŰ     (double acute accent)
 Alt+§ applicato ad Alt+§ aA                          : ˘ ăĂ  ĕĔ  ĭĬ      ŏŎ    ŭŬ     (breve)
 Alt+° applicato ad Alt+° aA                    uU    : ˚ åÅ                    ůŮ     (kroužek or ring)
 Alt+- applicato ad Alt+- aA  eE  iI      oO    uU    : ¯ āĀ  ēĒ  īĪ      ōŌ    ūŪ     (macron or long mark)
 Alt+: applicato ad alt+: aA  eE  iI      oO    uU    : ¨ äÄ  ëË  ïÏ      öÖ    üÜ     (diæresis or umlaut)
 Alt+^ applicato ad Alt+^ aA  eE  iI      oO    uU    : ^ â  êÊ  îÎ      ôÔ    ûÛ     (circumflex)
 Alt+£ applicato ad Alt+£ aA      iI    nNoO    uU    : ~ ãà      ĩĨ    ñÑõÕ    ũŨ     (tilde)
 Alt+= applicato ad Alt+= aA  eE  iI            uU    : ˛ ąĄ  ęĘ  įĮ            ųŲ     (ogonek)
 Alt+ç applicato ad Alt+ç   cC  gG  kKlLnN  rRsS      : ¸   çÇ  ģĢ  ķĶļĻņŅ  ŗŖşŞ       (cedilla or cédille)
                                                          ǎǍ  Ěě  ǐǏ      ǒǑ    ǔǓ     (caron)

Concatenare pdf con Ghostscript

Non vi è mai successo di dover concatenare due o più pdf (per esempio perché i compiti sono in file separati, mentre voi volete stamparle fronte retro)? Sicuramente sarete andati in cerca di chissà che programmi... Bene, sotto Linux è facile come scrivere un comando solo

 gs -q -sPAPERSIZE=a4 -dNOPAUSE -dBATCH -sDEVICE=pdfwrite -sOutputFile=out.pdf in1.pdf in2.pdf in3.pdf ...

Dove out.pdf è il file che volete creare, mentre in*.pdf sono quelli che volete concatenare.

Altrimenti usate pdftk.

Stampare da Linux con la finestra di KDE

Alcuni programmi Linux (per esempio Acrobat Reader) hanno una spartana finestra di stampa che permette di indicare solamente la linea di comando che volete utilizzare per stampare (di solito l'impostazione predefinita è /usr/bin/lpr). Se inserite in quella casellina kprinter, il vostro documento verrà passato al programma di stampa di KDE, che tra tutti è sicuramente quello con più opzioni e più facile da usare.

Firefox da l'errore: Firefox is already running but not responding...

Questo errore è dovuto al fatto che firefox è stato "chiuso male".. Per eliminarlo, andate nella cartella

 $HOME/.mozilla/firefox/[NUMERI A CASO].default/

Ed eliminate i file lock e .parentlock (OCCHIO: i file con il punto davanti sono file nascosti!)

Sezioni obsolete

Queste sezioni sono obsolete. Le lascio perchè contengono comunque informazioni utili.

Gmail e Konqueror

Il nuovo Konqueror (quello incluso nella versione 3.4 di KDE) supporta Gmail! Putroppo Gmail non supporta ancora Konqueror, dunque dovrete mascherarlo da Mozilla per riuscire a leggere la vostra posta usando l'interfaccia AJAX. Ecco come fare:

  1. Aprite il caro Konqueror
  2. Recatevi nella pagina di Login di Gmail
  3. Scegliete Mozilla 1.7.3 nel menu Tools/Change browser identification
  4. Inserite username e password
  5. Enjoy!


Accelerare l'accesso a Windows

Può capitare che il tempo necessario per entrare nel proprio account diventi molto lungo. Questo è dovuto solitamente all'accumulo di file di grossi dimensioni nel proprio profilo, che viene caricato nella directory C:\Documents and Settings\nome. Se questa directory occupa più di 30 MB, il computer può anche impedirti di uscire dall'account!

Lo spazio disponibile nel proprio profilo è quello riportato da un'iconcina in basso a destra che può avere una delle seguenti forme: File:Spazioprofilo.png. Facendo doppio clic, si apre una finestrella con la lista dei files presenti nel profilo, in ordine di dimensione: se si desidera rendere il profilo più 'leggero', un buon punto di partenza è eliminare quelli che compaiono ai primi posti.

Un paio di suggerimenti:

  • Non cancellare ciò che non si conosce; se si sospetta che un file possa essere necessario, lo si può spostare nella propria home, per poi ripristinarlo in caso di problemi;
  • Alcune directory possono essere nascoste: per vederle, selezionare Strumenti->Opzioni cartella->Visualizzazione->Visualizza cartelle e file nascosti;
  • Per eliminare Sfondo internet explorer.bmp senza cambiare lo sfondo del desktop, si può spostare l'immagine nella home e impostare lo sfondo dalla finestra delle proprietà dello schermo;
  • Se si usa (o si è usato) Firefox, si possono modificare le impostazioni in modo da ridurre lo spazio occupato, aprendo la finestra Tools->Options:
    • Da Advanced->Network, diminuire la dimensione massima della cache;
    • In alternativa, si può lasciare la cache e selezionare, in Privacy, la casella Always clear my private data when I close Firefox e, cliccando su Settings..., assicurarsi che Cache sia selezionata;
    • Il file urlclassifier2.sqlite contiene le informazioni sui siti contraffatti; se ritenete di poter fare a meno della protezione anti-phishing di Firefox e volete eliminare quel file, in Security deselezionate Tell me if the site I'm visiting is a sospected forgery; poi chiudete il browser ed eliminate il file.